”your device is not compatible with this item” flash doesn’t work on wildfire…